Come posso creare un template di VisualARQ personalizzato?

Quando iniziate un nuovo documento, potete scegliere tra un modello template di Rhino oppure un modello template di VisualARQ.

I template di Rhino includono di default solo uno stile di oggetto “standard” per ciascun tipo di oggetto di VisualARQ e non creano né edifici né livelli (piani).

I template di VisualARQ, invece, di default includono la libreria completa degli stili di oggetto e creano un edificio ed un livello (pavimento). Tutti i tipi di oggetto vengono creati su livelli (layer) specifici e a tutti gli stili di oggetto vengono assegnati degli attributi specifici.

In ciascun documento potete modificare gli stili di oggetto esistenti, eliminarli oppure crearne dei nuovi. Potete anche decidere in che livello verrà creato di default ciascun tipo di oggetto (Strumenti > Opzioni > Proprietà del documento > VisualARQ > Livelli).

E se volete iniziare un nuovo progetto in cui tutti gli oggetti vengano creati in un determinato livello?

E se volete che il nuovo progetto includa la libreria dei vostri stili di oggetto più usati?

E se volete che tutti questi stili di oggetto abbiano gli attributi che desiderate?

E se volete iniziare un nuovo progetto che, di default, contenga già un edificio e quattro livelli?

Dovete realizzare queste modifiche ogni volta che iniziate un nuovo progetto? Certo che no.

La soluzione è facile: 

Dopo aver preparato il vostro file personalizzato, salvatelo come modello (File > Salva come modello…). Nelle “Opzioni di Rhino”, potete vedere in che cartella vengono salvati i file modello: Strumenti > Opzioni > Opzioni di Rhino > File. Alla successiva apertura di un nuovo documento, il vostro modello template personalizzato apparirà nell’elenco.

(Nota: Ricordiamo che potete importare i nuovi stili di oggetto di VisualARQ in qualsiasi documento usando il comando _vaStiliImporta.)

Template di VisualARQ personalizzato